/ nodejs

package.json의 dependency 모듈 패치

ISSUE

passport-ldap을 이용해서 ldap을 연동했는데 한 가지 이슈가 발생했다.
passport-ldap에 의존성이 있는 ldapjs 모듈의 버전이 최신 버전이 아니라서 발생한 이슈가 있었다.

이를 해결하기 위해서 passport-ldap의 package.json의 ldapjs 버전을 수정해주면 손쉽게 해결이 된다.
문제는 이 모듈을 일단 배포를 해야 하는데…
이 부분을 고민을 하다가 github로 fork를 한 다음에 이 fork한 내용을 바라보게 package.json을 수정해서 해결했다.

...
    "passport-ldap": "git://github.com/niceilm/passport-ldap.git#650a58cfa80296092b23adf57866683229dcdf31",
...

https://npmjs.org/doc/json.html